Overblog Suivre ce blog
Editer l'article Administration Créer mon blog
9 juin 2010 3 09 /06 /juin /2010 09:25

Pour que les sites utilisant le Framework 4 puissent cohabiter avec des sites utilisant le Framework 2 ou 3.5 vous devez créer plusieurs pool d’application. En effet, plusieurs version du Framework ne peuvent pas tourner dans le même pool d’application.

 

Voici les étapes à suivre pour installer le Framework 4.

 

1- Installez le Framework 4 à partir du site de Microsoft puis redémarrez le serveur.

2- Dans le Gestionnaire de IIS6, allez dans le nœud “Extensions du service Web” et assurez vous que l’extension ASP.NET v4 est autorisé.

3- Faites un clique droit sur le nœud “Pools d’applications” puis, dans le menu, cliquez sur “Nouveau” puis “Pool d’application”.

4- Créez autant de pools qu’il y a de Framework utilisé sur votre serveur IIS6. Exemple : appPoolF3, appPoolF4 etc..

5- Faites un clique droit sur le nœud de votre site utilisant le Framework 4 puis dans le menu cliquez sur “Propriétés”.

6- Dans l’onglet “ASP.NET” assurez vous que c’est bien le Framework 4 qui est utilisé.

7- Dans l’onglet répertoire de base, modifier le Pool d’application utilisé pour mettre celui du Framework 4.

8- Modifiez tous les pools d’applications des autres sites du serveur pour les mettre dans le pool correspondant a la version de leur Framework.

 

Remarque : Si un seul site n’est pas dans le bon pool les autres sites ne fonctionneront pas.

Partager cet article

Repost 0
Published by Cyril - dans ASP.NET
commenter cet article

commentaires

http://seomysitepro.com 12/09/2014 15:01

It is the last version you can install it on windows. The newest releases do need hosts like vista and windows 8. It is good to move on to new versions and up-to-date softwares. Because that can make your life a lot easier!

Stephane 09/05/2011 10:41


Merci pour l'explication, ça a fonctionné directement.
J'avais pas trop le temps de regarder à ça je dois rendre mon travail début juin.